Problem

When starting the modern Office add-in, it immediately fails with error "Access is denied".

The issue is an corrupt IE localStorage that is necessary to run our add-in. Should only happen on Outlook for Windows or Outlook for Web when using Internet Explorer.

For advanced users, a lot of background information to the issue can be found here: https://stackoverflow.com/questions/13102116/access-denied-for-localstorage-in-ie10


Solutions

we have two ways here Clear Registry Cache and Set integrity level are recommended.

There might be different reasons for the issue, so please try the following steps one by one and check if it is working again


Solution: Clear Registry Cache

  • Close Outlook

  • Open Windows registry with tool regedit (Help)

  • Open the following tree path:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\Cache\
    CODE
  • Delete the whole key "Extensible Cache" including all subkeys

  • Repeat the same with the LowCache folder:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\LowCache\
    CODE
  • Delete the whole key "Extensible Cache" including all subkeys here too

  • Restart Outlook and check if it is working


Solution: set integrity level

  • Close Outlook

  • Open a command line - cmd (make sure to not run as administrator)

  • Run the following command to set the integrity level for the AppData/LocalLow correctly to "Low"

icacls %userprofile%\Appdata\LocalLow /t /setintegritylevel (OI)(CI)L
CODE
  • Restart Outlook and check if it works.